Anyone else have problems upgrading WPMu 2.6 with subdirectories?

I’ve been upgrading a number of different WPMu installations. And while the upgrades I did for WPMu 2.6 installations that ran on dynamic subdomains went smoothly, two installations I upgraded that run on subdirectories (a result of them being hosted on shared hosting that would do dynamic subdomains) ran into problems. The upgrade seemed to go fine, but when I tried to login into a blog other than the main blog (or even login as another user) it simply remains on the login screen that redirects to itself for all blogs except main.

I did a quick search and found this forum thread which suggests I’m not alone with this issue. I deleted all my plugins and mu-plugins,  cleared the cache and threw out the cookies. I even spent some time in the wp-config file, and double checked my .htaccess settings, all to no avail.  I’m sure a fix is forthcoming, or at least a hack, but until then I would perhap hold off on upgrading to WPMu 2.6 if you are using subdirectorties. I make this post because after the pollyanna screencast about upgrading to WPMu 2.6 I posted previously, I want to make clear that the upgrade was only tested with dynamic subdomains, not subdirectories.

This entry was posted in , wpmu, wpmu development. Bookmark the permalink.

One Response to Anyone else have problems upgrading WPMu 2.6 with subdirectories?

  1. Clay says:

    It appears that sewpafly may have a SOLUTION to this problem. I don’t have any subdirectory-based WPMU installs, so I can test it out. Does this work for you?

Leave a Reply

Your email address will not be published. Required fields are marked *